liuhui998's new blog

using octopress

Firefox8兼容安装keysnail

| Comments

今天在用firefox上网时,firefox突然冒了一个升级提示,我不小心就被升级到了8.0。

当时我并没有在意,结果发现我平时用的 keysnail 就不能用了,提示不兼容。

以前我也碰到过同样的问题,我估计是: keysnail.xpi 里的版本设置问题。
我猜是firefox的版本更新的太快了,keysnail的作者来不及更新,于是我决定自己动手。

用git: “”https://github.com/mooz/keysnail.git">https://github.com/mooz/keysnail.git" clone了 keysnail 的最新代码

执行了 “./set_version_info.rb”

提示:
Input next version of this addon: 8

我随便输了一个addon版本号: 8。

提示:
Input next max version for target application: 8

因为现在firefox的版本是8,我也输入个: 8。

最后再执行: "./createpackage.sh "

就会生成 “keysnail.xpi”

在执行"./createpackage.sh" 有一点要注意的是:

在 MacOSX 有可能会出现下面的提示:“./createpackage.sh:50: command not found: xsel”。这是作者想把一些命令的输出复制到系统剪贴板上,需要使用一个叫 “xsel” 的命令。我们这里不需要复制内容到剪贴板,只直把这一行用 “#” 注释掉就可以了。

Comments